Vulnerabilitatea FREAK afecteaza toate versiunile de Windows

freak-ssl-tls-vulnerabilitySaptamana trecuta am vorbit despre un bug de securitate descoperit recent, si care ar putea ameninta securitatea globala a Internetului.

Initial, expertii in securitate credeau ca vulnerabilitatea SSL/TLS, numita “FREAK”, nu afecteaza sistemul de operare Windows, dar Microsoft a confirmat joia trecuta ca toate versiunile sistemului sau de operare sunt afectate.

Potrivit Microsoft, vulnerabilitatea exista in Secure Channel (Schannel), un pachet de securitate care implementeaza protocoalele SSL/TLS. Astfel, un atacator poate exploata bug-ul pentru a face downgrade unei sesiuni criptate SSL/TLS, astfel incat aceasta sa utilizeze o cheie de criptare RSA mai slaba. Apoi, printr-un atac de tip man-in-the-middle (MitM), un atacator poate intercepta si decripta traficul criptat.

Cu toate acestea, Microsoft spune ca nu exista nicio dovada care sa sugereze ca vulnerabilitatea este exploatata in prezent.

“La finalizarea anchetei, Microsoft va lua masurile corespunzatoare pentru a-si proteja clientii. Cel mai probabil va fi emis un update de securitate prin intermediul procesului de patching lunar (Patch Tuesday) sau un update de securitate “out-of-cycle””, a declarat compania intr-un comunicat.

Intre timp, utilizatorii sunt sfatuiti sa dezactiveze RSA key exchange ciphers utilizand Group Policy Editor disponibil in Windows Vista si versiunile ulterioare de Windows. Aceasta solutie este eficienta deoarece un atac poate fi lansat numai in cazul in care serverul accepta chei de criptare RSA de calitate inferioara.

Leave a Reply

Your email address will not be published. Required fields are marked *