Un bug gasit in GnuTLS expune atacurilor utilizatorii de Linux

Cercetatorii in securitate au descoperit o vulnerabilitate in GnuTLS, o componenta a protocoalelor de comunicare securizata SSL, TLS și DTLS, dar si a tehnologiilor asociate acestora. Este asemanatoare cu OpenSSL, dar mai putin recunoscuta. Cu toate acestea, este folosita la scara larga si este inclusa by default in RedHat, Debian si Ubuntu, iar peste 200 de pachete de software pentru Linux depind de aceasta pentru a comunica prin SSL/TLS.

Conform ArsTechnica, bug-ul este capabil sa trimita date malware catre dispozitive cu conexiuni criptate HTTPS, permitand atacatorilor sa le controleze de la distanta.

Un patch pentru aceasta vulnerabilitate a fost lansat vineri, si se adreseaza versiunilor GnuTLS 3.1.23, 3.2.15 și 3.3.4 , cu toate ca bug-ul a fost descoperit in urma cu cel putin doua saptamani.

Vulnerabilitatea a fost gasita de Joonas Kuorilehto de la Codenomicon, aceeasi companie care a descoperit si bug-ul Heartbleed.

Rugam toti clientii de hosting care folosesc RedHat, Debian sau Ubuntu sa faca update cat mai repede la GnuTLS. Pentru mai multe detalii despre bug dati click aici.

Sursa

Leave a Reply

Your email address will not be published. Required fields are marked *