O noua vulnerabilitate descoperita in Apache Tomcat server

tomcatCercetatorii de securitate de la Trustwave au descoperit recent o noua vulnerabilitate care permite atacatorilor sa lanseze atacuri de tip denial-of-service impotriva site-urilor gazduite pe servere Apache Tomcat.

Apache Tomcat este un server web utilizat la scara larga pentru hosting de aplicatii web dezvoltate cu tehnologii Java Servlet si JavaServer Pages (JSP).

Noua vulnerabilitate de tip denial-of-service afecteaza Apache Commons FileUpload, un modul de sine statator pe care dezvoltatorii il pot utiliza pentru a adauga capacitatea de upload aplicatiilor web Java. Acest modul este de asemenea inclus by default si în Apache Tomcat versiunile 7 si 8.

De atunci, vulnerabilitatea a fost eliminata din noua versiune Commons FileUpload 1.3.1, care a fost lansata pe 7 februarie si din versiunea Tomcat 8.0.3 beta lansata pe 11 februarie. De asemenea, va urma sa fie lansat si Apache Tomcat 7.0.51, dar aceasta versiune a serverului nu este inca gata pentru a fi lansata.

Leave a Reply

Your email address will not be published. Required fields are marked *