Update-urile de securitatea de la cPanel se adreseaza modulelor Perl

Ieri, producatorul panoului de control pentru hosting, cPanel, a pus la dispozitia utilizatorilor sai informatii legate de update-urile de securitate pentru cPanel si WHM, lansate la inceputul acestei saptamani, oferind mai multe detalii referitoare la cele 5 vulnerabilitati de securitate pe care acestea le abordeaza.

Potrivit unui e-mail trimis utilizatorilor cPanel, majoritatea vulnerabilitatilor detectate de echipa de dezvoltare si asigurare a calitatii din cadrul companiei cPanel sunt legate de mai multe module Perl din cPanel si WHM, versiunile 11.30, 11.32 si 11.34.

Marti, cPanel a anuntat utilizatorii ca vor primi informatii referitoate la aceste update-uri in urmatoarele zile.

“Nu exista niciun motiv sa credem ca aceste vulnerabilitati sunt cunoscute de catre public. Ca atare, cPanel va oferi doar informatii limitate cu privire la aceste vulnerabilitati” scrie in e-mail-ul trimis de cPanel.

Acest update-uri vin la o luna dupa ce cPanel si WHM 11.34 au ajuns la versiunea STABLE.

cPanel spune ca modulul Perl Storable este utilizat pentru caching de date pe disc si transfer de date intre procese, iar de multe ori acesta traverseaza granitele dintre privilegii.

“Un utilizator local rau intentionat ar putea utiliza acest comportament pentru a injecta cod in structurile de date, permitand astfel executarea de cod si posibilitatea de dobandire a privilegiilor”, spune cPanel.

Detaliile complete ale fiecarei vulnerabilitati de securitate cPanel au fost postate pe site-ul cPanel.

Update-urile pentru fiecare versiune de cPanel vor fi facute in mod automat, cu exceptia cazului in care utilizatorul a dezactivat functia automata de update.

Leave a Reply

Your email address will not be published. Required fields are marked *